If no command is generated after you click Generate Fix Command for a Linux software vulnerability, you can refer to solutions described in this topic.

Solution

Locate the cause by using one of the following methods:
  • Check whether the version of the Security Center agent is earlier than required.

    If the version of the Security Center agent on your server is earlier than required, vulnerability scan may not be supported. If your Security Center agent is not automatically updated, we recommend that you manually install the latest agent. For more information, see Install the Security Center agent.

  • Check whether the Security Center agent is offline.

    If your Security Center agent is offline, you cannot generate fix commands by using the vulnerability management feature. We recommend that you troubleshoot problems and make sure that the Security Center agent on your server is online. For more information, see Troubleshoot the problem of Security Center agent going offline.