Use Data Transmission Service (DTS) to fully migrate data from a standalone MongoDB database to a MongoDB instance of any architecture.
Supported source and destination databases
|
Source database |
Destination database |
|
ApsaraDB for MongoDB |
ApsaraDB for MongoDB |
|
Self-managed database on an ECS instance |
Self-managed database on an ECS instance |
|
Self-managed database connected over Express Connect, VPN Gateway, or Smart Access Gateway |
Self-managed database connected over Express Connect, VPN Gateway, or Smart Access Gateway |
|
Self-managed database with a public IP address |
Self-managed database with a public IP address |
This example demonstrates migrating from an ApsaraDB for MongoDB standalone instance to an ApsaraDB for MongoDB instance of any architecture.
Prerequisites
-
You have created the source ApsaraDB for MongoDB standalone instance and the destination ApsaraDB for MongoDB instance. For more information, see Create a standalone instance, Create a replica set instance, and Create a sharded cluster instance.
NoteFor information about supported versions, see Migration solutions.
-
The destination ApsaraDB for MongoDB instance must have at least 10% more storage space than the source ApsaraDB for MongoDB instance uses.
-
If the destination ApsaraDB for MongoDB instance uses a sharded cluster architecture, create the databases and collections to be sharded, configure sharding, enable the balancer, and perform pre-sharding in the destination ApsaraDB for MongoDB instance based on your business requirements. For more information, see Configure sharding to maximize shard performance and How do I handle uneven data distribution in a MongoDB sharded cluster?.
NoteConfiguring sharding prevents all data from being migrated to a single shard, which degrades cluster performance. Enabling the balancer and performing pre-sharding helps avoid data skew.
Limitations
|
Type |
Description |
|
Source database limitations |
|
|
Other limitations |
|
|
Special case |
If the source is a self-managed MongoDB database, a primary/secondary switchover during migration will cause the task to fail. |
Billing
|
Migration type |
Instance configuration fee |
Internet traffic fee |
|
Schema migration and full data migration |
Free of charge. |
When the Access Method parameter of the destination database is set to Public IP Address, you are charged for Internet traffic. For more information, see Billing overview. |
Migration types
|
Migration type |
Description |
|
Schema migration |
Migrates object schemas from the source ApsaraDB for MongoDB instance to the destination ApsaraDB for MongoDB instance. Note
DTS supports schema migration for DATABASE, COLLECTION, and INDEX objects. |
|
Full data migration |
Migrates all existing data from the source ApsaraDB for MongoDB instance to the destination ApsaraDB for MongoDB instance. Note
DTS supports full data migration for data in DATABASE and COLLECTION objects. |
Permissions required for database accounts
|
Database |
Schema migration |
Full data migration |
|
Source ApsaraDB for MongoDB instance |
The read permission on the databases to be migrated and the config database. |
|
|
Destination ApsaraDB for MongoDB instance |
The dbAdminAnyDatabase permission, the readWrite permission on the destination databases, and the read permission on the local database. |
|
For information about creating and authorizing a database account for an ApsaraDB for MongoDB instance, see Manage MongoDB database users in DMS.
Procedure
-
Navigate to the migration task list page for the destination region using one of the following methods.
From the DTS console
-
Log on to the Data Transmission Service (DTS) console.
-
In the navigation pane on the left, click Data Migration.
-
In the upper-left corner of the page, select the region where the migration instance is located.
From the DMS console
NoteThe actual operations may vary based on the mode and layout of the DMS console. For more information, see Simple mode console and Customize the layout and style of the DMS console.
-
Log on to the Data Management (DMS) console.
-
In the top menu bar, choose .
-
To the right of Data Migration Tasks, select the region where the migration instance is located.
-
-
Click Create Task to navigate to the task configuration page.
-
Configure the source and destination databases.
WarningAfter you select the source and destination instances, we recommend that you carefully read the limits displayed at the top of the page. Otherwise, the task may fail or data inconsistency may occur.
Section
Parameter
Description
N/A
Task Name
DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.
Source Database
Select Existing Connection
-
To use a database instance that has been added to the system (created or saved), select the desired database instance from the drop-down list. The database information below will be automatically configured.
NoteIn the DMS console, this parameter is named Select a DMS database instance..
-
If you have not registered the database instance with the system, or do not need to use a registered instance, manually configure the database information below.
Database Type
Select MongoDB.
Access Method
Select Cloud instance.
Instance Region
Select the region where the source ApsaraDB for MongoDB instance resides.
Replicate Data Across Alibaba Cloud Accounts
In this example, a database instance under the current Alibaba Cloud account is used. Select No.
Architecture
Although the source is a standalone instance, select Replica Set for the Architecture setting.
-
Replica Set: Provides high availability and read/write splitting by deploying multiple node types. For more information, see Replica set architecture.
-
Sharded Cluster: Consists of mongos, shard, and ConfigServer components. You can customize the number and configurations of mongos and shard nodes. For more information, see Sharded cluster architecture.
Migration Method
A standalone source instance does not support incremental migration. Leave the Migration Method set to the default, Oplog, as this setting is required by DTS even for standalone sources.
Instance ID
Select the ID of the source ApsaraDB for MongoDB instance.
Authentication Database
Enter the name of the authentication database for the source ApsaraDB for MongoDB instance. The default is admin.
Database Account
Enter the database account of the source ApsaraDB for MongoDB instance. For permission requirements, see Permissions required for database accounts.
Database Password
Enter the password for the database account.
Encryption
DTS supports three connection methods: Non-encrypted, SSL-encrypted, and Mongo Atlas SSL. The options for Encryption vary based on the selected Access Method and Architecture. The options displayed in the console prevail.
Note-
A MongoDB database where the Architecture is Sharded Cluster and the Migration Method is Oplog does not support SSL-encrypted.
-
If the source is a self-managed MongoDB database (Access Method is not Alibaba Cloud Instance) with a Replica Set architecture, and you select SSL-encrypted, DTS also allows you to upload a CA certificate to verify the connection.
Destination Database
Select Existing Connection
-
To use a database instance that has been added to the system (created or saved), select the desired database instance from the drop-down list. The database information below will be automatically configured.
NoteIn the DMS console, this parameter is named Select a DMS database instance..
-
If you have not registered the database instance with the system, or do not need to use a registered instance, manually configure the database information below.
Database Type
Select MongoDB.
Access Method
Select Cloud instance.
Instance Region
Select the region where the destination ApsaraDB for MongoDB instance resides.
Replicate Data Across Alibaba Cloud Accounts
In this example, a database instance under the current Alibaba Cloud account is used. Select No.
Architecture
Select an architecture based on your business requirements:
-
Replica Set: Provides high availability and read/write splitting by deploying multiple node types. For more information, see Replica set architecture.
-
Sharded Cluster: Consists of mongos, shard, and ConfigServer components. You can customize the number and configurations of mongos and shard nodes. For more information, see Sharded cluster architecture.
Instance ID
Select the ID of the destination ApsaraDB for MongoDB instance.
Authentication Database
Enter the name of the authentication database for the destination ApsaraDB for MongoDB instance. The default is admin.
Database Account
Enter the database account of the destination ApsaraDB for MongoDB instance. For permission requirements, see Permissions required for database accounts.
Database Password
Enter the password for the database account.
Encryption
DTS supports three connection methods: Non-encrypted, SSL-encrypted, and Mongo Atlas SSL. The options for Encryption vary based on the selected Access Method and Architecture. The options displayed in the console prevail.
Note-
MongoDB databases with an Architecture of Sharded Cluster do not support SSL-encrypted.
-
If the destination is a self-managed MongoDB database (Access Method is not Alibaba Cloud Instance) with a Replica Set, and you select SSL-encrypted, DTS also allows you to upload a CA certificate to verify the connection.
-
-
After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page.
Note-
Ensure that the IP address segment of the DTS service is automatically or manually added to the security settings of the source and destination databases to allow access from DTS servers. For more information, see Add DTS server IP addresses to a whitelist.
-
If the source or destination database is a self-managed database (the Access Method is not Alibaba Cloud Instance), you must also click Test Connectivity in the CIDR Blocks of DTS Servers dialog box that appears.
-
-
Configure the task objects.
-
On the Configure Objects page, configure the objects that you want to migrate.
Parameter
Description
Migration Types
Select both Schema Migration and Full Data Migration.
NoteThis scenario does not support incremental migration. To ensure data consistency, do not write new data to the source instance during data migration.
For more information, see Migration types.
Processing Mode of Conflicting Tables
-
Precheck and Report Errors: Checks whether collections with the same names exist in the destination database. If no collections with the same names exist, the precheck is passed. If collections with the same names exist, an error is reported during the precheck, and the data migration task does not start.
NoteIf a collection in the destination database has the same name but cannot be easily deleted or renamed, you can change the name of the collection in the destination database. For more information, see Object name mapping.
-
Ignore Errors and Proceed: Skips the check for collections with the same names.
WarningSelecting Ignore Errors and Proceed may cause data inconsistency and business risks. For example:
-
If a record in the destination database has the same primary key value as a record in the source database, the record in the destination database is kept. The record from the source database is not migrated to the destination database.
-
Data initialization may fail, only some data may be migrated, or the migration may fail.
-
Capitalization of Object Names in Destination Instance
Configure the case sensitivity of database and collection names in the destination instance. By default, DTS default policy is selected. You can also align with the default policy of the source or destination. For more information, see Case sensitivity of object names in the destination instance.
Source Objects
In the Source Objects box, click the objects to migrate, and then click
to move them to the Selected Objects box.NoteSelect objects at the database or collection level.
Selected Objects
-
To set the name of a migration object in the destination instance, or to specify the object that receives data in the destination instance, right-click the migration object in the Selected Objects box to make changes. For more information, see Object name mapping.
-
To remove a selected migration object, click the object in the Selected Objects box, and then click
to move it to the Source Objects box.
Note-
To filter data based on conditions, which is supported during full data migration, right-click a collection in the Selected Objects box and configure the filter in the dialog box that appears. For more information, see Set filter conditions.
-
Retargeting a database or collection with object name mapping may cause dependent objects to fail during migration.
-
-
Click Next: Advanced Settings to configure advanced parameters.
Parameter
Description
Dedicated Cluster for Task Scheduling
By default, DTS schedules tasks on a shared cluster. You do not need to select one. If you want more stable tasks, you can purchase a dedicated cluster to run DTS migration tasks.
Retry Time for Failed Connections
After the migration task starts, if the connection to the source or destination database fails, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1440 minutes. We recommend that you set the duration to more than 30 minutes. If DTS reconnects to the source and destination databases within the specified duration, the migration task automatically resumes. Otherwise, the task fails.
Note-
For multiple DTS instances that share the same source or destination, the network retry time is determined by the setting of the last created task.
-
Because you are charged for the task during the connection retry period, we recommend that you customize the retry time based on your business needs, or release the DTS instance as soon as possible after the source and destination database instances are released.
Retry Time for Other Issues
After the migration task starts, if a non-connectivity issue, such as a DDL or DML execution exception, occurs in the source or destination database, DTS reports an error and immediately begins to retry the operation. The default retry duration is 10 minutes. You can customize the retry time to a value from 1 to 1440 minutes. We recommend that you set the duration to more than 10 minutes. If the related operations succeed within the specified retry duration, the migration task automatically resumes. Otherwise, the task fails.
ImportantThe value of Retry Time for Other Issues must be less than the value of Retry Time for Failed Connections.
Enable Throttling for Full Data Migration
During full migration, DTS consumes read and write resources on the source and destination databases, which may increase the database load. If required, you can enable throttling for the full migration task. You can set Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s) to reduce the load on the destination database.
Note-
This configuration item is available only if you select Full Data Migration for Migration Types.
-
You can also adjust the full migration speed after the migration instance is running.
Only one data type for primary key _id in a table of the data to be synchronized
In the data to be migrated, is the data type of the primary key
_iduniform within a single collection?Important-
Select an option based on your requirements. Otherwise, data loss may occur.
-
This parameter is available only if you select Full Data Migration for Migration Types.
-
Yes: The data type is unique. During full data migration, DTS does not scan the data types of primary keys in the source data. For a single collection, DTS migrates only the data corresponding to one primary key data type.
-
No: The data type is not unique. During full data migration, DTS scans the data types of primary keys in the source data and migrates all data.
Environment Tag
Optionally, select an environment tag to identify the instance.
Configure ETL
Based on your business needs, select whether to configure the ETL feature to process data.
-
Yes: Configures the ETL feature. You must also enter data processing statements in the text box.
-
No: Does not configure the ETL feature.
Monitoring and Alerting
Select whether to set alerts and receive alert notifications based on your business needs.
-
No: Does not set an alert.
-
Yes: Configure alerts by setting an alert threshold and an alert notifications. If a migration fails or the latency exceeds the threshold, the system sends an alert notification.
-
-
Click Next: Data Validation to configure a data validation task.
For more information about the data validation feature, see Configure data validation.
-
-
Save the task and run a precheck.
-
To view the parameters for configuring this instance when you call the API operation, move the pointer over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the bubble that appears.
-
If you do not need to view or have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.
Note-
Before the migration task starts, DTS performs a precheck. The task starts only after it passes the precheck.
-
If the precheck fails, click View Details next to the failed check item, fix the issue based on the prompt, and then run the precheck again.
-
If a warning is reported during the precheck:
-
For check items that cannot be ignored, click View Details next to the failed item, fix the issue based on the prompt, and then run the precheck again.
-
For check items that can be ignored, you can click Confirm Alert Details, Ignore, OK, and Precheck Again to skip the alert item and run the precheck again. If you choose to ignore a warning, it may cause issues such as data inconsistency and pose risks to your business.
-
-
-
Purchase the instance.
-
When the Success Rate is 100%, click Next: Purchase Instance.
-
On the Purchase page, select the link specification for the data migration instance. For more information, see the following table.
Category
Parameter
Description
New Instance Class
Resource Group Settings
Select the resource group to which the instance belongs. The default value is default resource group. For more information, see What is Resource Management?
Instance Class
DTS provides migration specifications with different performance levels. The link specification affects the migration speed. You can select a specification based on your business scenario. For more information, see Data migration link specifications.
-
After the configuration is complete, read and select Data Transmission Service (Pay-as-you-go) Service Terms.
-
Click Buy and Start. In the OK dialog box that appears, click OK.
You can view the progress of the migration task on the Data Migration Tasks list page.
Note-
If the migration task does not include incremental migration, it stops automatically after the full migration is complete. After the task stops, its Status changes to Completed.
-
If the migration task includes incremental migration, it does not stop automatically. The incremental migration task continues to run. While the incremental migration task is running, the Status of the task is Running.
-
-