none
Intern
Intern
  • UID5964
  • Fans0
  • Follows0
  • Posts1
Reads:49824Replies:2

Cannot List Directories via FTP

Created#
More Posted time:Jul 21, 2018 17:46 PM
After installing the vsftpd service and running it i ran into some errors.
Some of them were:
 (1) 530: Incorrect Login
 (2) Server sent a pass'ive reply unroutable address. Suing server Address instead
 (3) Something else related to chroot()

All of these problems were solved by removing write access to home directory, listing ftp_user in vsftpd.userlist file and allowing coonection to my Internet Address over port 22. But still i cannot retrieve the FTP directory which should be /home/ftp_user containg a file testFILE.txt.
I'm using FIleZilla as the FTP Client which gives me the following result

Status: Connecting to 47.74.228.56:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/"
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 227 Entering Passive Mode (47,74,228,56,224,192).
Command: LIST


I need to know how to properly setup the ftp server and use it. My ECS is Ubuntu 14.04 64-bit
Guest