none
Intern
Intern
  • UID5964
  • Fans0
  • Follows0
  • Posts1
Reads:49824Replies:2

Cannot List Directories via FTP

Created#
More Posted time:Jul 21, 2018 17:46 PM
After installing the vsftpd service and running it i ran into some errors.
Some of them were:
 (1) 530: Incorrect Login
 (2) Server sent a pass'ive reply unroutable address. Suing server Address instead
 (3) Something else related to chroot()

All of these problems were solved by removing write access to home directory, listing ftp_user in vsftpd.userlist file and allowing coonection to my Internet Address over port 22. But still i cannot retrieve the FTP directory which should be /home/ftp_user containg a file testFILE.txt.
I'm using FIleZilla as the FTP Client which gives me the following result

Status: Connecting to 47.74.228.56:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/"
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 227 Entering Passive Mode (47,74,228,56,224,192).
Command: LIST


I need to know how to properly setup the ftp server and use it. My ECS is Ubuntu 14.04 64-bit

GhulamQadir
Senior Engineer
Senior Engineer
  • UID5968
  • Fans4
  • Follows0
  • Posts98
1st Reply#
Posted time:Jul 22, 2018 4:21 AM
I suppose your mean FileZilla Server, right?


  1. Browse full assigned directory
Grant Directories > List permission.
  1. Deny downloads on everything or restricted amount (in size or count of files) of downloads per session
To deny downloads, just remove Files > Read permission.
Restricted amount of download is not supported. But you can impose download speed limit.
  1. Allow Uploads for new files
Grant Files > Write permission.
  1. Deny overrides for existing files
Grant Files > Write permission, but remove Files > Delete permission.
  1. Add multiple groups/users
See Edit > Users and Edit > Groups.
  1. Associate each user to a local directory path
Use Set as home dir button.

BrianBae
Assistant Engineer
Assistant Engineer
  • UID5909
  • Fans1
  • Follows0
  • Posts58
2nd Reply#
Posted time:Jul 21, 2018 20:53 PM
vsftp installed ok.
But if you want to use passive mode, you should add config more.

It seems like client couldn't change passive mode.

please add like below and open firewall port too..

edit  /etc/vsftpd/vsftpd.conf

pasv_enable=Yes
pasv_min_port=10090
pasv_max_port=10100

* open port 90 ~ 100 on firewall setting.

Good luck.
Guest