RohitGoel
Intern
Intern
  • UID5079
  • Fans0
  • Follows0
  • Posts16
Reads:569Replies:7

Windows instance Activation and Internet access

Created#
More Posted time:Mar 4, 2018 17:15 PM
Hi Team,


I have deployed windows instace and i observing below things. Could anyone please confirm is this is normal or is there any issue with the Alibaba Cloud ECS sevices?


- I see windows instance doesn't get activated once created. I believe once we spinup an instance, it gets activated automatically.

 - I see Instance doesn't seems to have internet access.



Same issue i see with Windows 2016 also.


any pointers will be appreciated.
Regards,
RohitGoel

Latest likes:

abdulhafeezabdulh...

abdulhafeez
Assistant Engineer
Assistant Engineer
  • UID4972
  • Fans4
  • Follows5
  • Posts48
1st Reply#
Posted time:Mar 5, 2018 16:26 PM
Hi Rohit,

To verify that KMS volume activation works, complete the following steps:

On the KMS host, open the event log and confirm that DNS publishing is successful.

On a client computer, open a Command Prompt window, type Slmgr.vbs /ato, and then press ENTER.

The /ato command causes the operating system to attempt activation by using whichever key has been installed in the operating system. The response should show the license state and detailed Windows version information.

On a client computer or the KMS host, open an elevated Command Prompt window, type Slmgr /dlv, and then press ENTER.

The /dlv command displays the detailed licensing information. The response should return an error that states that the KMS activation count is too low. This confirms that KMS is functioning correctly, even though the client has not been activated.

For more information about the use and syntax of slmgr.vbs, see Slmgr.vbs Options.
https://docs.microsoft.com/en-us/windows/deployment/volume-activation/activate-using-key-management-service-vamt

Regards,
Abdul Hafeez

abdulhafeez
Assistant Engineer
Assistant Engineer
  • UID4972
  • Fans4
  • Follows5
  • Posts48
2nd Reply#
Posted time:Mar 5, 2018 20:48 PM
For Internet Access:
if you don't have Public IP on ECS, then you can just create an Elastic IP and bind that IP to the ECS. After activation you can release Elastic IP.

RohitGoel
Intern
Intern
  • UID5079
  • Fans0
  • Follows0
  • Posts16
3rd Reply#
Posted time:Mar 5, 2018 22:20 PM
abdulhafeez:For Internet Access:
if you don't have Public IP on ECS, then you can just create an Elastic IP and bind that IP to the ...
回到原帖
While creating ECS Windows Instance, Instance was assigned public IP address. So do i still need to have Elastic IP and bind it to ECS? I believe Public IP Address assigned during the ECS Instance creation should be good for internet access in the Instance...

RohitGoel
Intern
Intern
  • UID5079
  • Fans0
  • Follows0
  • Posts16
4Floor#
Posted time:Mar 5, 2018 22:33 PM
Hi Abdul,

I have deleted the Instance anyway, but i'll try to recreate new and will check. However, why would we need to do this activity of activating ECS Instance manually? When we order ECS Instance, my understanding is that license should get activated automatically through Alibaba KMS. I am not sure if anyone has also faced the same issue with there ECS instance. Thanks

Regards,
Rohit Goel


Regards,
Rohit Goel

abdulhafeez
Assistant Engineer
Assistant Engineer
  • UID4972
  • Fans4
  • Follows5
  • Posts48
5Floor#
Posted time:Mar 6, 2018 1:38 AM
Yes, any new ECS instance shall get automatically activated by Alibaba KMS server, if not you can run "slmgr /ato" command for force activation.

This problem can be region specific only... not always. If your instance has public IP then why you can not access internet?

RohitGoel
Intern
Intern
  • UID5079
  • Fans0
  • Follows0
  • Posts16
6Floor#
Posted time:Mar 6, 2018 2:46 AM
Hi Abdul,

Unfortunately i didnt capture the screen shot..but i agree that it could be a region specific issue. Will give it a retry again...Thanks.

Regards,
Rohit

abdulhafeez
Assistant Engineer
Assistant Engineer
  • UID4972
  • Fans4
  • Follows5
  • Posts48
7Floor#
Posted time:Mar 6, 2018 2:50 AM
ok. no worries, let me know for further help.
Guest